Google Toolbar and Firefox Personas Plus Issue Fixed

We worked with Mozilla to resolve an incompatibility with Personas Plus 1.6.1, which caused Google Toolbar and a few other third-party extensions to
The incompatibility caused Toolbar to become non-responsive and a "slow script" error dialog to appear. Details of the bug can be found here.

Both Google and Mozilla have released fixes, and users experiencing this conflict should be automatically updated to the latest version of Google
Toolbar (7.1.20100830W) soon. If you can't wait, please feel free to visit http://toolbar.google.com to manually install the latest version over your
existing version.

Please report back if the problem persists.
blog comments powered by Disqus